[Vtigercrm-developers] assigned to field read only in profile?

Alan Lord (News) alanslists at gmail.com
Tue Aug 13 12:05:01 UTC 2013

On 13/08/13 12:49, Joe Bordes wrote:
> I forced that in the database to try it for a client and the whole
> edit/save process broke. It is because if it is read only it does not
> appear on the edit form but the save process expects this field to be
> there. So you would have to modify the database directly and then modify
> the code to support not having that field in sight.
> I may be wrong as I didn't dedicate much more time than a quick test
> modifying the database directly but the sensation i got is that
> "assigned to" is an important field which shouldn't be played with.
> I would suggest though a javascript/jquery hack to disable the field
> dynamically, that may be easier....  not sure though...

Thanks Joe,

I tried manually overriding the read-only setting in the 
vtiger_profile2field for a profile and fieldid.

It nearly worked. Assigned To is readonly but that user can't create new 
records :-(

Think I might follow up on your suggestion of looking at client-side 



Libertus Solutions

More information about the vtigercrm-developers mailing list